TCT Editor 3.0

USER’S MANUAL

Manual version 3.0.1

TCT Editor – the on-line trust case editor & management tool is developed by
Information Assurance Group
Department of Software Engineering
© Gdańsk University of Technology, 2008
All rights reserved
# Table of Contents

**INTRODUCTION** ................................................................................................................................................. 3

- About TCT Editor ...................................................................................................................................................... 3
- Access to TCT Editor .................................................................................................................................................. 4
- TCT Editor Main Screen Layout .............................................................................................................................. 4
- User roles in TCT Editor ........................................................................................................................................... 5

**TCT EDITOR KEY FEATURES** ......................................................................................................................................... 6

- Opening a project ................................................................................................................................................................. 6
- Creating a new project .......................................................................................................................................................... 6
- Editing project’s details ....................................................................................................................................................... 7
- Deleting a project ................................................................................................................................................................. 7
- Browsing the trust case ....................................................................................................................................................... 8
- Creating a new node ............................................................................................................................................................. 10
- Editing node details ............................................................................................................................................................ 10
- Editing references ............................................................................................................................................................... 11
- Viewing references .............................................................................................................................................................. 12
- Deleting a node ................................................................................................................................................................. 13
- Moving a node up or down ................................................................................................................................................ 14
- Copying nodes, cutting & pasting nodes ............................................................................................................................ 15
- Creating a link to a node ..................................................................................................................................................... 16
- Refreshing the trust case ................................................................................................................................................... 17
- Generating a report ........................................................................................................................................................... 18
- Assigning aggregation rules .............................................................................................................................................. 19
- Assigning weights ............................................................................................................................................................... 19
- Issuing assessments ......................................................................................................................................................... 20
- Viewing aggregated assessments ...................................................................................................................................... 21

**TCT EDITOR ADVANCED FEATURES** ................................................................................................................................................. 22

- Creating a new project’s version ........................................................................................................................................ 22
- Opening a project’s version ............................................................................................................................................... 22
- Deleting a project’s version ............................................................................................................................................. 23
- Copying a project ............................................................................................................................................................... 23
- Exporting a project to XML ............................................................................................................................................... 24
- Importing a project from XML ........................................................................................................................................ 25
- Viewing and editing my user’s account ................................................................................................................................ 25
- Configuring project’s repositories ..................................................................................................................................... 26
- Browsing a trust case with Traversal Tool .......................................................................................................................... 27
- Viewing change history of a node ....................................................................................................................................... 28
- Viewing links to a node ....................................................................................................................................................... 29
- Going to link target ............................................................................................................................................................ 30
- Selecting nodes to include in a report .................................................................................................................................. 30
- Deleting assessments .......................................................................................................................................................... 31
- Selecting an active view .................................................................................................................................................... 31
- Managing views ............................................................................................................................................................... 32
Introduction

About TCT Editor

TCT Editor is an on-line team-oriented software tool supporting development of argumentation structures – trust cases. Trust cases encompass the argument and related evidence, which together demonstrate that an object exhibits certain properties. Trust cases have a tree-like structure with several dedicated node types: claims, arguments with warrants, facts, assumptions, references, information nodes and links. TCT Editor can store many trust cases (and their versions) categorized into projects. General scenario of TCT Editor usage is presented below:

1. Open a trust case to develop – open a project, its specific version or create a new project
2. Define the object property to argue (e.g. system trustworthiness) as the top level claim of the trust case
3. Develop argument strategy to conclude about the argued claim from premises which are easier to be demonstrated
4. Identify and document premises
   a) Identify facts - statements of verified information about something that is the case or has happened
   b) Identify assumptions - statements assumed to be true for which no evidence is provided
   c) Identify sub-claims – statements to be further argued for
5. Identify documents with evidence to appropriate premises and attach them via references
Access to TCT Editor

**TCT Editor** is an online application accessed with an internet browser. It is best run under Firefox 2.0+, however Internet Explorer 7+ is also supported. Please make sure that session cookies and JavaScript are enabled in your browser.

To log in, enter your user's name and password and click the **log in** button.

**TCT Editor main screen layout**

- **Projects or trust case tree**
- **Details panel** (details of selected tree node)
- **Context menu**
- **Main menu**
- **User's role**
- **Version name**
- **Drag bar to resize tree and panel**
- **Button to hide or show detail panel**
- **Buttons to apply or cancel changes to selected tree node**
User roles in TCT Editor

TCT Editor distinguishes the following roles of users:
- Viewer – browses projects and trust cases, cannot edit anything
- Developer – creates and manages projects, edits trust cases
- Assessor – evaluates trust cases, cannot edit projects or trust cases
- Administrator – manages user’s accounts, can use all features

The list of the TCT Editor features available to particular roles is given below:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Viewer</th>
<th>Developer</th>
<th>Assessor</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>TCT Editor key features</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Opening a project</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Creating a new project</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Editing project’s details</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Deleting a project</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Browsing the trust case</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Creating a new node</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Editing node details</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Editing references</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Viewing references</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Deleting a node</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Moving a node up or down</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Copying nodes, cutting &amp; pasting nodes</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Creating a link to a node</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Refreshing the trust case</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Generating a report</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Assigning aggregation rules</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Assigning weights</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Issuing assessments</td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Viewing aggregated assessments</td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td><strong>TCT Editor advanced features</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Creating a new project’s version</td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Opening a project’s version</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Deleting a project’s version</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Copying a project</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Exporting a project to xml</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Importing a project from xml</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Viewing and editing my user’s account</td>
<td>✓¹</td>
<td>✓¹</td>
<td>✓¹</td>
</tr>
<tr>
<td>Configuring project’s repositories</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Browsing a trust case with traversal tool</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Viewing change history of a node</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Viewing links to a node</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Going to link target</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Selecting nodes to include in a report</td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Deleting assessments</td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Selecting an active view</td>
<td>✓</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Managing views</td>
<td></td>
<td>✓</td>
<td></td>
</tr>
</tbody>
</table>

¹ Editing only if permitted by the administrator on per-account basis
Opening a project

5. Select a project in the project’s tree

6. Choose **Project -> Open** from the main menu

*Alternatively, you can choose *Open* from the project’s context menu.*

Latest project version will be open.

Creating a new project

1. Choose **Project -> New** from the main menu

*Alternatively, you can choose *New* from the context menu of *Projects* tree node.*

A new untitled project will be created and added to the projects tree. You can then edit its details to define title and description for the new project.
Editing project’s details

1. Select a project from the projects’ tree. The project’s details will be shown in Details Panel.
2. Enter the new project’s name and description
3. Click Apply

Deleting a project

1. Select a project in the project’s tree
2. Choose Project -> Delete from the main menu

Alternatively, you can choose Delete from the project’s context menu.

WARNING: All versions are deleted. No undo is provided.
Browsing the trust case

Opening nodes:

1. Click the cross sign next to a node icon
The tree will be expanded and all children of the node will be shown.

Displaying node details:

1. Select a node from the tree
Information about the selected node will be displayed in the details panel.
Expand all:

1. Open the context menu for a node that should be expanded
2. Choose **Expand all**

   Alternatively, you can select a node and choose **View -> Expand All** from the main menu.

The branch of the tree is expanded and all the descendants of the node are displayed.

Collapse all:

1. Open the context menu for a node that should be collapsed
2. Choose **Collapse All**

   Alternatively, you can select a node and choose **View -> Collapse All** from the main menu.

The branch of the tree is collapsed and all the branches of all the descendants of the node are collapsed.
Creating a new node

1. Open the context menu for a parent node of a new node and choose **New node**

   *Alternatively, you can select a node and choose *Edit -> New Node* from the main menu.*

2. Choose a node type from the list of types of nodes, which can be created

   **WARNING:** Warrant node is created automatically with argument. It cannot be added separately.

Editing node details

1. Select a node which should be edited

2. Enter the new details for the node (e.g. node name, description, state)

3. Click **Apply**
Editing references

1. Select a reference node to edit

2. Enter the common details for the node (e.g. node name, description, state)

3. Configure the referred resource. If the referred resource (a file) is stored in a pre-configured repository, tick the **Repository resource** checkbox (3a), select the **Repository** (3b) and enter the relative path to the file within the repository (3c). If the referred resource (a file) is available directly in the Internet, uncheck the **Repository resource** checkbox (3a) and enter the resource full URL (3c).

4. With **Inline** checkbox choose whether the referred resource will be put within the main report body (checked) or included in an appendix to the report (unchecked)

5. Click **Apply** to save the changes to the node
Viewing references

1. Select a reference node to view

2. To view the reference choose View Reference from the details panel

   Alternatively, you can choose View Reference from the context menu of the reference node (or link to such node) or select the reference node (or link to such node) and choose View -> View Reference from the main menu.
Deleting a node

1. Open the context menu of a node
2. Choose Delete

Alternatively, you can select a node and choose Edit -> Delete from the main menu.

WARNING: You cannot delete a node which is a link target – delete all links to this node first. You cannot also delete a tree branch if it contains link targets of links from outside of this branch. If a link target is detected, it is opened in the details panel after the error message.

WARNING: You cannot delete a warrant node. It is deleted together with its argument.
Moving a node up or down

Moving a node up:

1. Open the context menu of a node which should be moved up
2. Choose Move Up
   
   *Alternatively, you can select a node and choose Edit -> Move Up from the main menu.*

Moving a node down:

1. Open the context menu of a node which should be moved down
2. Choose Move Down

   *Alternatively, you can select a node and choose Edit -> Move Down from the main menu.*

**TIP:** Move up or Move down option is not available for the first (excluding warrant) and last child node respectively.

**WARNING:** You cannot move up or down the warrant node. It must be the first child node of its parent argument.
Copying nodes, cutting & pasting nodes

1. Open the context menu of a node to copy or cut (together with all its descendants)

2. Choose Copy or Cut.

   Alternatively, you can select a node and choose Edit -> Copy or Edit -> Cut from the main menu.

   The NODE CLIPBOARD window will appear if it wasn’t opened before.

3. Open the context menu of the node which should be the new parent of the copied or cut node (and its descendant nodes)

4. Choose Paste

   You can also select a node and choose Edit -> Paste from the main menu or choose Paste in the NODE CLIPBOARD window.

TIP: Paste option is not available if the type of the copied or cut node is not among the allowed children types of the selected parent node.

WARNING: You cannot cut or copy the warrant node.
Creating a link to a node

1. Open the context menu of the node which will be the target of a new link.
2. Choose Copy.
   Alternatively, you can select a node and choose Edit -> Copy from the main menu.
   The NODE CLIPBOARD window will appear if it wasn't opened before.
3. Open the context menu of the node which will be the parent of a new link.
4. Choose Paste as Link.
   Alternatively, you can choose Paste as Link button of the NODE CLIPBOARD window or Edit -> Paste as Link from the main menu.

**TIP:** Paste as Link option is not available if the node type of the link target is not among the allowed children types of the selected parent node.

**WARNING:** You cannot create link to a warrant node or to another link.
Refreshing the trust case

1. Open the context menu for a node that should be refreshed
2. Choose Refresh

Alternatively, you can select a node and choose View -> Refresh from the main menu.

The branch of the tree is reloaded so that it contains the current branch content that might have been changed by other people working simultaneously on the same trust case.
Generating a report

1. Choose a node which descendants should be included in a report

2. Choose **Project -> Generate Report** from the main menu

3. To generate a report with default settings click **OK (3b)** in the window which appears. To set up properties of a report which will be generated choose appropriate options by selecting radio buttons in the configuration panel (3a) before you click **OK (3b)**. You can:
   a. select a report file format (available formats: RTF, HTML, PDF)
   b. enable or disable the numeration of pages
   c. set a number of the report first page
   d. enable or disable information in the report about the last modification date of nodes
   e. allow or not to additionally generate an appendix with graphic presentation of the trust case tree
   f. choose page orientation (portrait or landscape) of the appendix with graphic presentation of the trust case tree

4. If a report is generated successfully the browser window is displayed making it possible to save the generated report. Save the report in a convenient place on your local computer. If you chose a HTML format of the report during the report configuration step or if you attached the appendix, a ZIP archive will be generated with all report files.
Assigning aggregation rules

1. Select a warrant node in the trust case tree
2. Choose a Description tab
3. Choose an appropriate Rule from the drop down list
4. Choose Apply to save the chosen aggregation rule

Assigning weights

1. Select a premise (i.e. an assumption, claim or fact) of an argument whose warrant’s rule is set to C-rule
2. Choose Description tab
3. Choose an appropriate Weight from the slide-bar
4. Choose Apply to save the chosen weight

WARNING: The weight is assigned in the selected active view.
Issuing assessments

1. Select a node, which is an **assumption**, **fact** or **warrant without a supporting argument**, and has not been assessed yet using the account that the user works with.

2. Choose **Trust evaluation** tab.

3. Choose **Create assessment**.

As a result, a new assessment is created with a default value set to 'lack of confidence'.

4. Choose an appropriate confidence level (4a) and decision (4b) using the slide-bars.

5. Alternatively (instead of step 4) choose an appropriate assessment using the pointer on the opinion triangle. The horizontal dimension (red – green scale) represents your decision, while the vertical dimension (red/green – yellow) represents your confidence in the decision.

6. To confirm and save your assessment choose **Apply**.
Viewing aggregated assessments

1. Select a node, which is an argument, assumption, claim, fact or warrant
2. Choose Trust evaluation tab
3. See the aggregated assessment of this node
Creating a new project’s version

1. Select a project in the project’s tree
2. Choose **Project -> New Version** from the main menu

Alternatively, you can choose **New Version** from the project’s context menu.

As a result a new version is created. It is a copy of the last created version. It becomes a default version for the project, which means that it is opened when a project is opened (see the following clause).

Opening a project’s version

1. Expand the project’s list of versions (**1a**) and select a project’s version to open (**1b**) 
2. Choose **Project -> Open** from the main menu

Alternatively, you can choose **Open** from the project version’s context menu.

22
Deleting a project’s version

1. Select a project’s version to delete
2. Choose **Project -> Delete Version** from the main menu

   Alternatively, you can choose **Delete Version** from the project version’s context menu.

**TIP:** The last and only project version cannot be deleted. Delete the entire project instead.

**WARNING:** No undo is provided. You cannot undelete a deleted project version.

Copying a project

1. Select a project in the project’s tree
2. Choose **Project -> Copy** from the main menu

   Alternatively, you can choose **Copy** from the project’s context menu.

A new project is created with a copy of the last created version of the selected project.
Exporting a project to XML

1. Select a project in the project’s tree

2. Choose **Project -> Export to XML** from the main menu

   Alternatively, you can choose **Export to XML** from the project’s context menu.

3. If a project is exported successfully you see an information explaining that the exported file does not contain historic node versions, and logins and passwords for repositories (**3a**). Additionally a browser window is displayed allowing to save the exported TCT file (**3b**). Save this file in a convenient place on your local computer.

   All versions of the selected project are exported to the TCT file.
Importing a project from XML

1. Choose **Project -> Import from XML** from the main menu (or from Projects’ context menu)
2. Press **Browse...**, select a TCT file to import from your local computer (**2a**) and click **OK** (**2b**) If a project is imported successfully you see a confirmation message and a new project appears in the projects tree.

Viewing and editing my user’s account

1. Choose **Account -> My Account** from the main menu
2. You may be allowed only to view your user’s account or to change the account details and the password. If you are allowed to modify your account, enter the new details of your account (**2a**) and click **Modify** (**2b**)
3. To modify the password, click **Set Password** (**2c**) 
4. Enter a new password in two fields (**3a**) and click **OK** (**3b**)
Configuring project’s repositories

In TCT Editor, source documents and images for references are stored in online repositories accessed with URL. If a repository is secured, user’s login name and password is also required.

1. Choose **Project -> Configure -> Repositories** from the main menu

2. To add a new repository click **New (2a)**. The new repository is given a default name. To modify a repository, select it in the list, enter a new name and a URL and click **Modify (2b)**. To change login and password to a repository click **Set Login & Password (2c)**. In the window which appears (3) provide a login and password and click **OK (3a)**. To delete a repository select it in the list and click **Delete (2d)**. Click **Close (2e)** to finish configuring the repositories.

**WARNING:** All changes made in this window are directly applied to the repositories list.

**WARNING:** Repositories which are used by references in the trust case tree or repositories which are used by historic versions of references cannot be deleted.
Browsing a trust case with Traversal Tool

Traversal Tool remembers which nodes have been selected while browsing the trust case and allows to go back and forth among the selected nodes in the order in which they have been selected. Its main use is to easily go back to a previously selected node to do/check something and then return to the current node of interest.

1. Choose View -> Traversal Tool from the main menu to show the tool

2. In the left bottom corner of the trust case tree area the Traversal Tool appears. Using the arrows of the tool you can browse the trust case according to the history of visited (selected) nodes. To go back to previously selected nodes choose the left arrow (2a). To go forth to nodes selected later on choose the right arrow (2b). If the history of visited nodes is not available, an appropriate arrow is grayed out.

The Traversal Tool is transparent but you can always hide it choosing View -> Traversal Tool (1) from the main menu again.
Viewing change history of a node

1. Choose a node
2. In the details panel choose **Change history** tab
3. Open the drop-down list
4. Choose an item in the list

A historic version of the node information will be displayed in the tab. The list contains the history of all the changes of the node information since its creation.

**WARNING:** The tab provides only browsing capabilities so that it is not possible to undo changes by clicking apply (which is not active).

**WARNING:** Historic versions of links are displayed together with their link target (as in description tab). However, the link target is a node from the trust case tree instead of its historic version.
Viewing links to a node

1. Select a node

2. Choose **Links to node** tab
   - The list contains all the links that have the selected node as their target, if any.

3. To go to a link node targeting the selected node choose this link node from the list (3a) and choose **Go to link** button (3b)
Going to link target

1. Select a link which has a target
2. Choose Go to link target

As a result, the link target is selected in the tree and displayed in the Details Panel.

Selecting nodes to include in a report

You can decide, which nodes (branches) of the trust case tree will be put in the generated report. As a default, all nodes in a trust case tree are set as "included in report". If you don't want to include some nodes (with their descendants) in the report, you should edit the node details and uncheck Include in report checkbox (1) in the Description tab.
Deleting assessments

1. Select a node, which is an assumption, fact or warrant without an argument, and has already been assessed using the account that the user works with.

2. Choose Trust evaluation tab

3. Choose Delete assessment

Selecting an active view

1. Click on the View tab

2. Open Trust Views

3. Select Second view

4. Click on the Active view: Main view

5. Click on the Activate button
1. Open the View menu from main menu
2. Select Trust Views menu option

A Trust Evaluation Views Manager window appears

3. Choose an appropriate view from the list
4. Choose Activate (the name of the newly activated view is written in red color in the list now)
5. Choose Close to close the window
6. As a result a new name of the active view is displayed in node description

WARNING: The view is activated for the current session only. Default view is restored in new session.

Managing views

1. Open Trust Evaluation Views Manager window
2. To create a new view, choose New (2a). To modify an existing view select it from the list (2b), type a new name and description (2c) and choose Modify (2d). To delete a view select it from the list (2b) and choose Delete (2e). To change the default view, select a view to make default from the list (2b) and choose Default (2f).
3. Once done, choose Close to close the Trust Evaluation Views Manager window